[rspec-users] no output from rspec

David Chelimsky dchelimsky at gmail.com
Mon Oct 18 09:26:36 EDT 2010


On Oct 18, 2010, at 1:24 AM, Todd Sedano wrote:
> At one point, I had rspec working with my system and I've must have changed the configuration because now I don't see anything in the output using rspec 1.3. 
> 
> Just to be clear, I see nothing when I type 
> spec spec
> rake spec
> bundle exec spec spec
> bundle exec rake spec
> (or any of the above with a specific spec file.)
> 
> I didn't see a debug option to see what is going wrong.

$ spec -h
Usage: spec (FILE(:LINE)?|DIRECTORY|GLOB)+ [options]
    ...
    -u, --debugger                   Enable ruby-debugging.

> I'm using bundler. (Gemfile http://gist.github.com/631809). I've tried uninstalling rspec 1.3 and rspec 2.0 (et al) My specs are in my rails directory (ie project/spec) I'm on leopard (10.5.8) Just to be safe, I blew out the bundler directories ( rm -rf ~/.bundle/ ~/.gem/ .bundle/ vendor/cache/ Gemfile.lock) and the ~/.rvm directory
> 
> Ironically, everything works nicely on my build machine.
> 
> I'm eagerly waiting for my move to Rails 3, this just isn't a good time for me yet 
> 
> I just tried creating a new project using the same Gemfile and it looks like it is working in a vanilla rails project. I'm not sure where to begin to see what my current project is doing to create this problem. 
> 
> Any thoughts?

First thought: that sucks!

Second thought: this has happened before.

Third thought: http://www.google.com/search?q=rspec+no+output

I'm sure you'll find your answer in there. If someone else has the answer at the top of his/her head, please follow up here.

Cheers,
David

> Thanks!
> 
> Todd
> 
> Ps. I'm assuming that I can't use rspec 2.0.0 and rspec-rails-1.3

ps - there is a project up on github that works with early beta versions of rspec-2: http://github.com/rsanheim/rspec-rails23 but it has yet to be updated to rspec-2.0.0. Someone should fork and update it. I will eventually if nobody else does, but it's going to be a few weeks before I can get to it.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20101018/689344d0/attachment-0001.html>


More information about the rspec-users mailing list