[rspec-users] no output from rspec

Todd Sedano todd.sedano at sv.cmu.edu
Mon Oct 18 02:24:12 EDT 2010

At one point, I had rspec working with my system and I've must have changed
the configuration because now I don't see anything in the output using rspec

Just to be clear, I see nothing when I type
spec spec
rake spec
bundle exec spec spec
bundle exec rake spec
(or any of the above with a specific spec file.)

I didn't see a debug option to see what is going wrong.

I'm using bundler. (Gemfile http://gist.github.com/631809). I've tried
uninstalling rspec 1.3 and rspec 2.0 (et al) My specs are in my rails
directory (ie project/spec) I'm on leopard (10.5.8) Just to be safe, I blew
out the bundler directories ( rm -rf ~/.bundle/ ~/.gem/ .bundle/
vendor/cache/ Gemfile.lock) and the ~/.rvm directory

Ironically, everything works nicely on my build machine.

I'm eagerly waiting for my move to Rails 3, this just isn't a good time for
me yet

I just tried creating a new project using the same Gemfile and it looks like
it is working in a vanilla rails project. I'm not sure where to begin to see
what my current project is doing to create this problem.

Any thoughts?



Ps. I'm assuming that I can't use rspec 2.0.0 and rspec-rails-1.3
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20101017/44832399/attachment.html>

More information about the rspec-users mailing list