[rspec-users] no such file to load -- spec/rake/spectask

David Chelimsky dchelimsky at gmail.com
Wed Oct 13 10:27:56 EDT 2010


On Wed, Oct 13, 2010 at 8:30 AM, Matt Davies <lists at ruby-forum.com> wrote:
> Hi David
>
> I understand what you're saying, but the only thing I can think of(I'm
> using bundler and there are no gems installed prior to running bundle
> install) is that
>
> gem 'rspec-rails', '1.2.9'
>
> must depend on rspec >= 2.0

It depends on rspec >= 1.2.9 (any version 1.2.9 and up). Bundler sees
that and installs the newest version of rspec, which in this case was
2.0.0.

Whereas, rspec-rails-1.3.3 depends on rspec = 1.3.1 (only 1.3.1), so
it installs a compatible version.

Future releases of rspec will use "pessimistic" version constraints
for its requirements (see
http://docs.rubygems.org/read/chapter/16#page74), so this shouldn't be
a problem going forward.

> Otherwise I have no idea how rspec 2.0 was getting into the gem list

Cheers,
David

p.s. Please be sure to quote relevant parts of the discussion to make
it easier for everyone to follow the conversation in a single message.


More information about the rspec-users mailing list