[rspec-users] using rcov with rspec2

nathanvda nathanvda at gmail.com
Wed Oct 6 04:25:22 EDT 2010



On 5 okt, 15:17, David Chelimsky <dchelim... at gmail.com> wrote:
> On Tue, Oct 5, 2010 at 7:28 AM, David Chelimsky <dchelim... at gmail.com> wrote:
> > On Tue, Oct 5, 2010 at 6:20 AM, nathanvda <nathan... at gmail.com> wrote:
> >> On Oct 4, 3:24 am, Will Marshall <li... at ruby-forum.com> wrote:
> >>> > The error i get is this:
>
> >>> > `require': no such file to load -- spec_helper (LoadError)
>
> >>> The only solution I have found for this is to revert from rspec-rails
> >>> beta.22 to rspec-rails beta.20
>
> > Please post replies inline or at the bottom (I moved yours from the top).
>
> >> I hoped the new rspec2.0.0.rc would fix it, but it doesn't.
>
> >> I hope anybody can shed any light on this?
>
> > I'll need more information as rcov + rspec-2.0.0.rc is working just
> > fine for me. Please report this to
> >http://github.com/rspec/rspec-core/issuesand include OS, ruby
> > version, and the full backtrace you are seeing.
>
> Actually somebody just reported this tohttp://github.com/rspec/rspec-rails/issuesand I figured out the
> problem and fixed it in rspec-rails.
>
> I've also addedhttp://github.com/rspec/rspec-core/issues/issue/172to
> address this now that I understand the problem. Feel free to comment
> on that issue rather than adding a new one.
>
> Cheers,
> David

Thanks David, that helped me out!


More information about the rspec-users mailing list