[rspec-users] "no such file to load -- sqlite3" error

Dean Richardson lists at ruby-forum.com
Thu Nov 11 14:32:33 EST 2010


Luis:

Since your suggested change to database.yml got rake db:test:prepare to 
work when using mysql for the test database, I went ahead and tried to 
rake spec and rake cucumber for my app.

"rake spec" produced the same error that originally led to this thread:

rake aborted!

***************************************************************************
*  You are trying to run an rspec rake task defined in
*  /Users/Lowell/rails_projects/genlighten_dr/lib/tasks/rspec.rake,
*  but rspec can not be found in vendor/gems, vendor/plugins or system 
gems.
***************************************************************************

Fortunately, however entering 'spec spec/' works fine (i.e., produces no 
output and a command prompt, since my app currently has no tests.)

I worry that I have some gems in

     /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby 
/gems/1.8/gems

(rails 2.3.5, for instance, but not rspec or cucumber) and lots of other 
gems in

     /Library/Ruby/Gems/1.8/gems

(another copy of rails 2.3.5, plus rspec and components, cucumber and 
components, and a ton of other stuff)

and that the rake task is confused about where to look.

Any suggestions on whether that might be the issue and if so, how to 
address it?

Thanks once more...

Dean

Luis Lavena wrote in post #960735:
> On Thu, Nov 11, 2010 at 9:49 AM, Dean Richardson <lists at ruby-forum.com>
> wrote:
>> presence of the sqlite3-ruby gem and other associated dependencies. The
>> overflow, etc., but none of the fixes I've found so far there seem to
>> help.
>>
>> Any suggestions for how to make either test database approach (sqlite3
>> or mysql) work would be greatly appreciated.
>>
>
> Hello,
>
> To better understand what is going on with sqlite3 adapter will
> require more details.
>
> As for the mysql error, in your database.yml, just copy your
> configuration from development section and rename the database to your
> test one.
>
> Ensure the socket line is not there, as is the one affecting your
> mysql execution.
>
> HTH,
> --
> Luis Lavena
> AREA 17
> -
> Perfection in design is achieved not when there is nothing more to add,
> but rather when there is nothing more to take away.
> Antoine de Saint-Exupry

-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list