[rspec-users] "no such file to load -- sqlite3" error

Dean Richardson lists at ruby-forum.com
Thu Nov 11 10:48:08 EST 2010


This was really helpful advice. I went ahead and simply created the 
"showtime" rails app using the guidelines under section 19.3 of The 
RSpec Book:

No problems whatsoever with rake db:test:prepare. This should have been 
obvious to me because I just went through that chapter a few weeks back.

I then went into the config directory for showtime and changed the 
database.yml file... so that the development and test sections looked 
like they do in my genlighten app. I repeated rake db:test:prepare, and 
it still worked fine.

Of course, when I went through Michael Hartl's Rails Tutorial book 
several months ago, I was able to use rspec and rake db:test:prepare 
there successfully, in another directory on my same machine, so it 
shouldn't surprise me that a "clean" app works.

Unfortunately, however, I'm afraid I'm still clueless as to what's so 
different about the genlighten app's configuration/setup that it fails 
to find sqlite3 (if that's even what's really going on...)


BTW, your suggested fix to the "test:" section in my database.yml file 
for using mysql on my test database worked flawlessly. Thanks!

Luis Lavena wrote in post #960752:
> On Thu, Nov 11, 2010 at 11:40 AM, Dean Richardson <lists at ruby-forum.com>
> wrote:
>> Hi Luis:
>> Thanks for the rapid response. I'll work on your MySQL fix... in the
>> meantime, what further details can I provide regarding the sqlite3
>> adapter issue?
> If you can create a simple new rails application it will use sqlite3
> by default, try to execute rake db:migrate and db:test:prepare there
> and see if the error is reproducible.
> --
> Luis Lavena
> AREA 17
> -
> Perfection in design is achieved not when there is nothing more to add,
> but rather when there is nothing more to take away.
> Antoine de Saint-Exupry

Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list