[rspec-users] [Rails] `parse!': invalid option: --autotest (OptionParser::InvalidOption)

David Chelimsky dchelimsky at gmail.com
Wed Nov 10 11:05:53 EST 2010


On Nov 8, 2010, at 10:10 AM, Justin Malone wrote:

> Well, here it is. I am learning Rails and rSpec at the same time courtesy of Michael Hartl's tutorial. All was going good when this happened. rspec is woking on my other projects so I have no idea what I did wrong. I tryed removing files one by one from 'spec' directory to see if one of the files was jacked up but I either get nothing or this same thing. Please help if you know what I did wrong.
> 
> ----------------------------------------------
> 
> When i run $ autotest, here is what I get back:    
> 
> bundle exec /usr/local/bin/ruby -S /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.0.1/bin/rspec --autotest '/Users/justin/Projects/hno/spec/controllers/pages_controller_spec.rb' '/Users/justin/Projects/hno/spec/controllers/sessions_controller_spec.rb' '/Users/justin/Projects/hno/spec/controllers/users_controller_spec.rb' '/Users/justin/Projects/hno/spec/models/user_spec.rb' '/Users/justin/Projects/hno/spec/requests/layout_links_spec.rb' '/Users/justin/Projects/hno/spec/requests/users_spec.rb'
> /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.0.0.beta.18/lib/rspec/core/option_parser.rb:17:in `parse!': invalid option: --autotest (OptionParser::InvalidOption)
>     from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.0.0.beta.18/lib/rspec/core/option_parser.rb:4:in `parse!'
>     from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.0.0.beta.18/lib/rspec/core/configuration_options.rb:64:in `parse_command_line_options'
>     from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.0.0.beta.18/lib/rspec/core/configuration_options.rb:46:in `parse_options'
>     from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.0.0.beta.18/lib/rspec/core/runner.rb:32:in `run'
>     from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.0.0.beta.18/lib/rspec/core/runner.rb:10:in `block in autorun'

Looks like you've got rspec-core-2.0.1 and rspec-core-2.0.0.beta.18. I'd recommend uninstalling the beta.

HTH,
David


More information about the rspec-users mailing list