[rspec-users] no output from rspec -- fixed

Todd Sedano todd.sedano at sv.cmu.edu
Tue Nov 9 21:21:29 EST 2010


Resend from 10/29/2010 due to bounce back. This is in reference to an email
sent to the group on On Oct 18, 2010, at 1:24 AM.

Short version: The solution was indeed to downgrade to test-unit 1.2.3

gem 'test-unit', '1.2.3'



Longer version: I went through my github repository and found a version

of my gemfile that worked with rspec. I then carefully compared the two

versions and by process of elimination figured out what went wrong. My

earlier Gemfile did not specify test-unit. Ironically, I had seen this

solution posted on the internet and am convinced that I tried

test-unit 1.2.3 on several occasions, but either I was doing something

wrong, or bundler was confused, or somehow test-unit 2.x.x was sneaking

in even when I was explicitly calling 1.2.3 -- I'm happy to have specs

running again!



> At one point, I had rspec working with my system and I've must have changed
> the configuration because now I don't see anything in the output using rspec
> 1.3.

> Just to be clear, I see nothing when I type
> spec spec
> rake spec
> bundle exec spec spec
> bundle exec rake spec
> (or any of the above with a specific spec file.)

>

>

> I didn't see a debug option to see what is going wrong.

> I'm using bundler. (Gemfile http://gist.github.com/631809). I've tried

> uninstalling rspec 1.3 and rspec 2.0 (et al) My specs are in my rails

> directory (ie project/spec) I'm on leopard (10.5.8) Just to be safe, I
blew > out the bundler directories ( rm -rf ~/.bundle/ ~/.gem/ .bundle/ >
vendor/cache/ Gemfile.lock) and the ~/.rvm directory

>

> Ironically, everything works nicely on my build machine.

> I'm eagerly waiting for my move to Rails 3, this just isn't a good time
for > me yet > I just tried creating a new project using the same Gemfile
and it looks like > it is working in a vanilla rails project. I'm not sure
where to begin to see > what my current project is doing to create this
problem. > Any thoughts?

>

> Thanks! > Todd > Ps. I'm assuming that I can't use rspec 2.0.0 and
rspec-rails-1.3
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20101109/3c6de99e/attachment.html>


More information about the rspec-users mailing list