[rspec-users] "rspec can not be found in vendor/gems, vendor/plugins or system gems" error

Dean Richardson lists at ruby-forum.com
Tue Nov 9 07:38:58 EST 2010

David Chelimsky wrote in post #960173:
> On Nov 8, 2010, at 12:40 PM, Dean Richardson wrote:
>> rspec-rails (1.3.2)
>> I started by installing rspec-rails 1.3.2, then cucumber-rails 0.3.2,
>> then database_cleaner and webrat. I then tried to run rake spec and got
>> the "rspec can not be found" error message. Taking this message
>> literally, I then ran "gem install rspec" and was able to install the
>> rspec-2.1.0 gem.
>> But when I ran rake spec again, I got the same error message as before.
>> Should I have installed an earlier version of the rspec gem?
> Did you get the most recent update to the beta book? If not, go log into
> your PragProg account and get it. There's a section in the preface that
> lists all the versions you need, including Rails-3 (not rails-2.3.5) and
> RSpec-2.
> HTH,
> David


Thanks for prompting me to get the update of the book. So, if I'm not 
quite ready to make the leap to Rails 3, am I out of luck trying to use 
RSpec and Cucumber? Is there any intermediate strategy you can suggest?


Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list