[rspec-users] Rails 3, Rspec 2, Autotest

dchelimsky at gmail.com dchelimsky at gmail.com
Wed May 12 21:04:14 EDT 2010


On May 9, 8:43 am, Scott Woods <scott.a.wo... at gmail.com> wrote:
> I get a slightly different error when following the gist. Here is my
> error, in case the extra data point helps:
>
> $ autotest
> loading autotest/rails_rspec_rspec2
> Error loading Autotest style autotest/rails_rspec_rspec2 (no such file
> to load -- autotest/rails_rspec_rspec2). Aborting.
>
> Note the extra "rspec" in the path that it's trying to load.

That's because autotest looks in the gem paths and the load path for
any files named autotest/discover.rb. It's finding the one in the
rspec-1.3.0 gem, which adds 'rspec', and the one in your app, which is
probably adding 'rspec2'.

Try adding a file to your app named autotest/rails_rspec_rspec2.rb and
require 'autotest/rails_rspec2' in that file. Let us know if that
works.

>
> Here is some more info about my environment:
>
> woods at beidleheimer ~/src/git/example $ gem list rspec
>
> *** LOCAL GEMS ***
>
> rspec (2.0.0.beta.8, 1.3.0, 1.2.9, 1.2.8, 1.2.6, 1.2.2, 1.2.0, 1.1.9,
> 1.1.3, 1.1.0)
> rspec-core (2.0.0.beta.8)
> rspec-expectations (2.0.0.beta.8)
> rspec-mocks (2.0.0.beta.8)
> rspec-rails (1.3.2, 1.2.9, 1.2.7.1, 1.2.6, 1.2.2, 1.2.0, 1.1.9)
> woods at beidleheimer ~/src/git/example $ gem list rails
>
> *** LOCAL GEMS ***
>
> rails (3.0.0.beta3, 2.3.5, 2.3.4, 2.3.3, 2.3.2, 2.2.2, 2.1.2, 2.1.1,
> 2.1.0, 2.0.4, 2.0.2, 2.0.1, 1.2.3)
> woods at beidleheimer ~/src/git/example $ ruby --version
> ruby 1.8.7 (2009-06-12 patchlevel 174) [i686-darwin10]
>
> On Apr 17, 10:42 am, Tim Riendeau <t... at wanlord.com> wrote:
>
>
>
> > I am having similar issue getting this working. I am running rails3.beta3 with ruby 1.8.7. I followedhttp://gist.github.com/365816andI get the following:
>
> > loading autotest/rails_rspec2
> > Autotest style autotest/rails_rspec2 doesn't seem to exist. Aborting.
>
> > I uninstalled and reinstalled the ZenTest & autotest gems with no luck. The same thing occurs in other rails3 apps.
>
> > Any help would be much appreciated
>
> > --Tim
>
> > On Apr 15, 2010, at 11:40 AM, Mark Pittillo wrote:
>
> > > Trying to set up a Rails 3 project with RSpec and Autotest.  I followed
> > > these steps exactly:
>
> > >http://gist.github.com/365816
>
> > > But when I start up autotest, I get:
>
> > > $ autotest
> > > loading autotest/rails
> > > style: Rails
>
> > > instead of:
>
> > > $ autotest
> > > loading autotest/rails_rspec2
> > > style: RailsRspec2
>
> > > And autotest doesn't seem to do anything.  Any idea what's happening?
> > > I'm using Ruby 1.9.2-head in rvm.  Relevant gems:
>
> > > autotest (4.2.9)
> > > autotest-rails (4.1.0)
> > > rspec (2.0.0.beta.6)
> > > rspec-core (2.0.0.beta.6)
> > > rspec-expectations (2.0.0.beta.6)
> > > rspec-mocks (2.0.0.beta.6)
> > > rspec-rails (2.0.0.beta.6)
> > > ZenTest (4.3.1)
>
> > > Thanks a lot for any help.
> > > Mark
> > > --
> > > Posted viahttp://www.ruby-forum.com/.
> > > _______________________________________________
> > > rspec-users mailing list
> > > rspec-us... at rubyforge.org
> > >http://rubyforge.org/mailman/listinfo/rspec-users
>
> >  smime.p7s
> > 5KViewDownload
>
> > _______________________________________________
> > rspec-users mailing list
> > rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users
>
> _______________________________________________
> rspec-users mailing list
> rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users
>
> --
> You received this message because you are subscribed to the Google Groups "rspec" group.
> To post to this group, send email to rspec at googlegroups.com.
> To unsubscribe from this group, send email to rspec+unsubscribe at googlegroups.com.
> For more options, visit this group athttp://groups.google.com/group/rspec?hl=en.


More information about the rspec-users mailing list