[rspec-users] autotest - garbled output

Matthew O'riordan lists at ruby-forum.com
Tue Mar 30 11:51:05 EDT 2010

I recently reinstalled my gems for autotest, and since then I have
unintelligible output coming from autotest like this (note everything
after unit_diff -u)

loading autotest/rails
-I.:lib:test -rubygems -e "%w[test/unit test/unit/test.rb].each { |f|
require f }" | unit_diff -u

Strangely I have run my tests individually and they work fine.
I have then tried running autotest in another Rails application and it
works fine.
I have uninstalled and reinstalled all gems related to autotest, and
same problem.
I then deleted my ~/.autotest file so it's vanilla and that makes no
Finally, I installed autotest-growl to see what output is coming through
to that, and that works fine and I get the results of my passed / failed
tests, but the console for autotest continues to just pump out a string
of numbers instead of a description of the tests it is running.

I am using ruby 1.8.7

The following gems are installed:
autotest (4.2.9)
autotest-growl (0.2.3)
autotest-rails (4.1.0)

I have tried enabling and disabling redgreen, but to no avail.

Please can someone help me, I am absolutely stumped.

Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list