[rspec-users] Autospec doing nothing

Ed Howland ed.howland at gmail.com
Tue Jun 29 19:34:07 EDT 2010


Hi, does anyone know how to modify this to work on Lucid?

I have libnotify installed, but haven't figured out how to get ZenTest
4.3 to work with growl on Ubuntu.


Cheers,
Ed

Ed Howland
http://greenprogrammer.wordpress.com
http://twitter.com/ed_howland



On Mon, Jun 21, 2010 at 9:02 AM, Tattoo <tatu.kairi at gmail.com> wrote:
> To get this working, I had to comment out line 21:
>
> SPEC_PROGRAM = File.expand_path(File.join(File.dirname(__FILE__),
> '..', '..', 'bin', 'spec'))
>
> My output said that I already had SPEC_PROGRAM initialized and also
> this line made it point to ../../bin/spec where I do not have spec
> installed (correct place for me was ~/.gem/ruby/1.8/bin/spec). I doubt
> for many, the situation is the same.
>
> Are you sure this line is necessary?
>
>
> On May 29, 4:26 am, Rodrigo Flores <m... at rodrigoflores.org> wrote:
>> I discovered the solution
>>
>> I have to put this on the .autotest file
>>
>> http://pastie.textmate.org/982730
>>
>>
>>
>>
>>
>> On Sun, May 9, 2010 at 09:56, Rodrigo Flores <m... at rodrigoflores.org> wrote:
>> > Ops
>>
>> > I searched on the list archive and I found a topic from a month ago about
>> > this. My ZenTest version is 4.3.1
>>
>> > My .autotest file is in my ~ and contains only
>> > require "autotest/growl"
>>
>> > rake spec is running succesfully.
>>
>> > On Sun, May 9, 2010 at 09:45, Rodrigo Flores <m... at rodrigoflores.org>wrote:
>>
>> >> Hi
>>
>> >> When I run autospec on a rails project I get nothing.
>>
>> >> flores at Suomi(9:41)~/Code/Sabbre/camisa10 % autospec
>> >> (Not running features.  To run features in autotest, set
>> >> AUTOFEATURE=true.)
>> >> (Not running features.  To run features in autotest, set
>> >> AUTOFEATURE=true.)
>> >> loading autotest/rails_rspec
>> >> style: RailsRspec
>>
>> >> --------------------------------------------------------------------------- -----
>>
>> >> (a bunch of blank lines)
>>
>> >> flores at Suomi(9:41)~/Code/Sabbre/camisa10 %
>>
>> >> Any ideas ?
>>
>> >> My Operating System is Mac OS X Snow Leopard, my ruby is 1.8.7.
>>
>> >> Rspec: 1.3.0
>> >> Rspec-Rails: 1.3.2
>> >> autotest: 4.2.9
>> >> autotest-growl : 0.2.4, 0.2.3
>> >> autotest-rails: 4.1.0
>>
>> >> --
>> >> ===================
>> >> Rodrigo L. M. Flores
>> >> Computer Science Msc. Student - IME - USP
>> >> Computer Science Degree - IME - USP
>> >> Homepage (en):http://www.rodrigoflores.org
>> >> Blog (pt-BR):http://blog.rodrigoflores.org
>> >> Linux User # : 351304
>> >> Jabber: i... at rodrigoflores.org
>>
>> > --
>> > ===================
>> > Rodrigo L. M. Flores
>> > Computer Science Msc. Student - IME - USP
>> > Computer Science Degree - IME - USP
>> > Homepage (en):http://www.rodrigoflores.org
>> > Blog (pt-BR):http://blog.rodrigoflores.org
>> > Linux User # : 351304
>> > Jabber: i... at rodrigoflores.org
>>
>> --
>> ===================
>> Rodrigo L. M. Flores
>> Computer Science Msc. Student - IME - USP
>> Computer Science Degree - IME - USP
>> Homepage (en):http://www.rodrigoflores.org
>> Blog (pt-BR):http://blog.rodrigoflores.org
>> Linux User # : 351304
>> Jabber: i... at rodrigoflores.org
>>
>> _______________________________________________
>> rspec-users mailing list
>> rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list