[rspec-users] Rake spec failure in beta.13

David Chelimsky dchelimsky at gmail.com
Sat Jun 26 13:30:55 EDT 2010

On Jun 26, 2010, at 12:13 PM, David Chelimsky wrote:

> On Jun 25, 2010, at 4:51 PM, geetarista wrote:
>> Sorry about that. For some reason I thought Google Reader stripped
>> that automatically.
>> I added ":require => nil" because I had read somewhere that it was
>> good to do so.  Can't remember why or where.  Taking it out does not
>> fix the failure.
>> I just haven't upgraded Haml because it's not top priority and I
>> haven't run into any issues yet.
> I've been able to reproduce the issue, and should have a fix in place soon.
> Assuming I've got the fix, I'll explain what happened once it's pushed to github.

What I believe to be the fix is now up in github. Geetarista, would you do me a favor and update your gemfile to point to the git repos:

gem "rspec-rails", :git => "git://github.com/rspec/rspec-rails.git"
gem "rspec-core", :git => "git://github.com/rspec/rspec-core.git"
gem "rspec-expectations", :git => "git://github.com/rspec/rspec-expectations.git"
gem "rspec-mocks", :git => "git://github.com/rspec/rspec-mocks.git"
gem "rspec", :git => "git://github.com/rspec/rspec.git"

Need to get all of them from git for this to work (just temporary until I get a release out).

Then 'bundle install' and 'rake spec' and let me know if all is well.


More information about the rspec-users mailing list