[rspec-users] Rake spec failure in beta.13

geetarista geetarista at gmail.com
Thu Jun 24 23:36:32 EDT 2010


Here's the backtrace and the spec file: http://gist.github.com/452355

Also, if I delete that spec file, it just goes to the next
alphabetical file and gives the same error for that model name.

On Jun 24, 8:21 pm, David Chelimsky <dchelim... at gmail.com> wrote:
> On Thu, Jun 24, 2010 at 10:12 PM, geetarista <geetari... at gmail.com> wrote:
>
> > On Jun 24, 7:10 pm, David Chelimsky <dchelim... at gmail.com> wrote:
> >> On Jun 24, 2010, at 2:24 PM, geetarista wrote:
>
> >> > On Jun 24, 12:03 pm, David Chelimsky <dchelim... at gmail.com> wrote:
> >> >> On Jun 24, 2010, at 1:23 PM, geetarista wrote:
>
> >> >>> I just upgraded to beta.13 and I'm running into an issue where when I
> >> >>> run 'rake spec', I get an 'uninitialized constant Comment' error.
> >> >>> Comment is the first model (alphabetically) in my project.  If I
> >> >>> switch back to beta.12, it works.  If I use 'spec .' and not 'rake
> >> >>> spec', it also works.
>
> >> >>> Environment: Rails master, Mongoid master.
>
> >> >> Did you run 'bundle update'?
> >> > I did both 'bundle install' and 'bundle update'.
>
> >> Did you upgrade rails as well? rspec-rails-2.0.0.beta.13 only works with rails-3.0.0.beta4.
>
> > I'm using Rails master.
>
> I'm at a loss. Please run "rake spec --trace" and post the full backtrace.
> _______________________________________________
> rspec-users mailing list
> rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users


More information about the rspec-users mailing list