[rspec-users] rspec(-rails).2.0.0.beta.13: no such file to load -- action_view/testing/resolvers

David Chelimsky dchelimsky at gmail.com
Thu Jun 24 21:47:14 EDT 2010


On Jun 24, 2010, at 1:37 AM, anywho wrote:

> Running into issues with latest rspec beta.
> 
> Beta.12 works flawlessly. Any insights are appriciated.
> 
> /mnt/bob/bob.building.app/vendor/bundle/gems/activesupport-3.0.0.beta3/

rspec-rails-2.0.0.beta.13 only works with rails-3.0.0.beta4.

HTH,
David

> lib/active_support/dependencies.rb:209:in `require': no such file to
> load -- action_view/testing/resolvers (LoadError)
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `block in require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:197:in
> `load_dependency'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/rspec-
> rails-2.0.0.beta.13/lib/rspec/rails/view_rendering.rb:2:in `<top
> (required)>'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `block in require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:197:in
> `load_dependency'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/rspec-
> rails-2.0.0.beta.13/lib/rspec/rails.rb:4:in `<top (required)>'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `block in require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:197:in
> `load_dependency'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `require'
> 	from /mnt/bob/bob.building.app/spec/spec_helper.rb:5:in `<top
> (required)>'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `block in require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:197:in
> `load_dependency'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `require'
> 	from /mnt/bob/bob.building.app/spec/models/landings_variation_spec.rb:
> 1:in `<top (required)>'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `block in require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:197:in
> `load_dependency'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/
> activesupport-3.0.0.beta3/lib/active_support/dependencies.rb:209:in
> `require'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/rspec-
> core-2.0.0.beta.13/lib/rspec/core/configuration.rb:250:in `block in
> require_files_to_run'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/rspec-
> core-2.0.0.beta.13/lib/rspec/core/configuration.rb:250:in `map'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/rspec-
> core-2.0.0.beta.13/lib/rspec/core/configuration.rb:250:in
> `require_files_to_run'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/rspec-
> core-2.0.0.beta.13/lib/rspec/core/command_line.rb:12:in `initialize'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/rspec-
> core-2.0.0.beta.13/lib/rspec/core/runner.rb:46:in `new'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/rspec-
> core-2.0.0.beta.13/lib/rspec/core/runner.rb:46:in `run_in_process'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/rspec-
> core-2.0.0.beta.13/lib/rspec/core/runner.rb:37:in `run'
> 	from /mnt/bob/bob.building.app/vendor/bundle/gems/rspec-
> core-2.0.0.beta.13/lib/rspec/core/runner.rb:22:in `block in autorun'
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users



More information about the rspec-users mailing list