[rspec-users] rspec-rails 2.0.0.beta.12 showing undefined method error for route_to

Daniel Salmeron Amselem daniel.amselem at gmail.com
Sun Jun 20 14:58:52 EDT 2010

First of all, I've been trying to find an answer for this problem all
over the internet without luck.

The thing is that I am using RVM with ruby 1.9.2-head and I created a
new empty gemset. Then I installed bundler gem with:

gem bundler install

That installed the library into the /Users/damselem/.rvm/gems/
ruby-1.9.2-head at rails3/gems directory. Then I went to my rails 3 app
directory and I ran "bundle install" which showed this:


and when I ran gem list I got:


Everything seems perfect, but when running some route specs I got an
undefined method error for route_to method. I've checked in the github
repository and it actually exists. So I decided to look inside the
library but I couldn't find the /rspec/rails/matchers/
routing_spec_matchers.rb directory and either the matchers directory.
So, my question is: Why is not the file in there? Why is not the
matchers directory either?

Then I found under /Users/damselem/.rvm/gems/ruby-1.9.2-head at rails3/ a
bundler directory with some gems, and with folder names like:


Why is that? Why there are two different directories for gems? Why are
devise, formtastic and shoulda not in the gems directory?

Thank you very much, and sorry for asking so many questions, but I'm
quite lost with all this.

More information about the rspec-users mailing list