[rspec-users] I'm having a couple of nuisance things happening with jruby and rspec

Greg Ditrick gditrick at fuse.net
Mon Jun 14 11:24:56 EDT 2010

Hi all,

I have a couple of things that are happening when using jruby.

1) I consistently getting a 'Command <cmd> failed' raised when using rake.  The Kernel.system() call on line ~ 176 of lib/spec/rake/spectask.rb is always returning false.  I'm not sure why. The specs run and work.  Does anyone or has anyone have this happen?  I run without rake and it works fine.  It's as if the Kernel.system() call is returning a negative false condition all the time.  jruby issue?

2) jruby on Windows does not produce colors.  I tried piping to wac and it parses out the color chars, but everything is still mono.  If I add a puts in my spec file with color chars that will be in color but the spec run will be in mono.  It is like rspec gem is doing something funky with the terminal/console output stream if it is jruby.  Any ideas here?

jruby 1.5

Here is my gem list:

*** LOCAL GEMS ***

actionmailer (2.3.8, 2.3.5)
actionpack (2.3.8, 2.3.5)
activerecord (2.3.8, 2.3.5)
activeresource (2.3.8, 2.3.5)
activesupport (2.3.8, 2.3.5)
builder (2.1.2)
columnize (0.3.1)
faker (0.3.1)
jruby-openssl (0.7)
machinist (1.0.6)
rack (1.1.0, 1.0.1)
rails (2.3.8, 2.3.5)
rake (0.8.7)
rspec (1.3.0)
ruby-debug (0.10.3)
ruby-debug-base (
sequel (3.12.1, 3.11.0)
sources (0.0.1)

I have to use jruby and windows for these tests.  The Rails ENV is used just for convenience of loading gems.  This is not a web app.  I'm using rspec to unit test DB stored procedures.

Thanks in advanced for nay insight to why I'm getting these,


More information about the rspec-users mailing list