[rspec-users] how to fix 'rake gems:refresh_specs' gems has no specificati

Amit Jain lists at ruby-forum.com
Thu Jul 29 07:37:26 EDT 2010


David Chelimsky wrote:
> On Jul 29, 2010, at 5:19 AM, Amit Jain wrote:
>> Hello,
>> I recently unpacked the latest rspec and rspec rails in my
>> applicaiton.
> 
> How did you unpack them (what command did you use)?
I just install rspec gem through the commands:
              root# gem install rspec
              root# gem install rcov

and

~/mygreatapp/ $ ./script/plugin install 
svn://rubyforge.org/var/svn/rspec/tags/REL_X_Y_Z/vendor/rspec_on_rails/vendor/plugins/rspec

but it's not work

~/mygreatapp/ $ ./script/generate rspec
and then
./script/generate rspec_model User

> 
>> When I run my specs I get:
>> 
>> $ rcov user_spec.rb
> 
> Where are you typing this command? What happens when you type "rake 
> spec" from the project root?
> I run that command in /spec/models directory

 /spec/models $ rcov user_spec.rb

>> config.gem: Unpacked gem CVS in vendor/gems has no specification file.
> 
> This error suggests that you unpacked the gem using "gem unpack" instead 
> of "rake gems:unpack".
> 
>> Run 'rake gems:refresh_specs' to fix this.
>> config.gem: Unpacked gem CVS in vendor/gems not in a versioned
>> directory. Giving up.
> 
> And this one suggests that you may have put a CVS plugin directly in the 
> gems folder. Rails wants you to put plugins in vendor/plugins, and use 
> "rake gems:unpack" to install gems in vendor/gems.
> 
>>  from
>> /home/Amit/Myworkspace/MyApplication/vendor/plugins/rspec_on_rails/lib/spec/rails.rb:3
> 
> What version of rails are you using? rspec_on_rails was replaced by 
> rspec-rails nearly two years ago, when rails was at 2.1.x. If you're 
> using any version of rails later than 2.1, you should be using the 
> rspec-rails gem.

I am using Rails 2.3.4.
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list