[rspec-users] how to fix 'rake gems:refresh_specs' gems has no specificati

Amit Jain lists at ruby-forum.com
Thu Jul 29 06:19:00 EDT 2010


Hello,
I recently unpacked the latest rspec and rspec rails in my
applicaiton.
When I run my specs I get:

$ rcov user_spec.rb
config.gem: Unpacked gem CVS in vendor/gems has no specification file.
Run 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem CVS in vendor/gems not in a versioned
directory. Giving up.
config.gem: Unpacked gem rmagick-2.13.1 in vendor/gems has no
specification file. Run 'rake gems:refresh_specs' to fix this.
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require': no such file to load -- application
(MissingSourceFile)
  from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/home/Amit/Myworkspace/MyApplication/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in
`require'
  from
/home/Amit/Myworkspace/MyApplication/vendor/plugins/rspec_on_rails/lib/spec/rails.rb:3
  from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/home/Amit/Myworkspace/MyApplication/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in
`require'
  from ./../spec_helper.rb:6
  from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from ./user_spec.rb:1
  from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.8/bin/rcov:511:in `load'
  from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.8/bin/rcov:511
  from /usr/bin/rcov:19:in `load'
  from /usr/bin/rcov:19
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list