[rspec-users] rspec rake tasks fail inside active record

andreyr andrey.rusetskiy at gmail.com
Thu Jul 8 04:29:38 EDT 2010

Hi David,

it would be  difficult to do as I would need to post something like 15 files
that are used in the spec file, otherwise the code would make no sense.
However, I have solved the problem. While trying to make a meaningful
example for you, I narrowed the problem down to the single line of code
which is 

require 'firewatir'

This is an older module not needed anymore and it was creating the problem.
After dropping it things started to work. It definitely was not an rspec
problem, even though it looked so from the error messages. 

I am still wondering why running the same spec file with the spec command
worked but with rake did not. I noticed that the list of loaded modules is
different when running with spec as compared to running with rake. Spec
loads activesupport much earlier than rake and I think this is the answer -
by the time when firewatir wants to access logger in case of using spec it's
already there but in case of rake not.

Anyway the problem is solved, thanks for your help.

David Chelimsky-2 wrote:
> We need to see some code. Please post the Rakefile and spec file.

View this message in context: http://old.nabble.com/rspec-rake-tasks-fail-inside-active-record-tp29084492p29100748.html
Sent from the rspec-users mailing list archive at Nabble.com.

More information about the rspec-users mailing list