[rspec-users] more verbosity for be_an?

rogerdpack rogerdpack at gmail.com
Sat Jan 2 21:43:14 EST 2010

> > The very first test I thought up was "this method should return an
> > integer" so kind of a basic test for a not yet existent method.
> Isn't this a bit anti-ruby though. Surely the things we should be testing is
> that the object exists, responds to certain messages and gives certain
> values back for those messages. Thinking about types is so Java, C++ :-)

Yeah, though it's a bit hard when it's supposed to return the pid of
some external process :)


More information about the rspec-users mailing list