[rspec-users] more verbosity for be_an?
apremdas at gmail.com
Sat Jan 2 16:23:23 EST 2010
2009/12/30 rogerdpack <rogerpack2005 at gmail.com>
> > What about something like:
> > expected #<Class:2158174640> => Fixnum to be a kind of Fixnum
> > That is more aligned with other failure messages. WDYT?
> I quite like it.
> In this instance it was
> 3.class.should be_a Fixnum # fails
> I suppose it would be something like
> expected #<Class:Fixnum> => Class to be a kind of Fixnum
> > And just out of curiosity, Roger, what's your use case? I can't remember
> ever using be_a/be_an, at least not in any code that has survived.
> The very first test I thought up was "this method should return an
> integer" so kind of a basic test for a not yet existent method.
Isn't this a bit anti-ruby though. Surely the things we should be testing is
that the object exists, responds to certain messages and gives certain
values back for those messages. Thinking about types is so Java, C++ :-)
> rspec-users mailing list
> rspec-users at rubyforge.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the rspec-users