[rspec-users] running rspec complains about missing cucumber-rails

katari at gmail.com katari at gmail.com
Tue Feb 16 12:03:12 EST 2010


Hello,
I can run cucumber tests, but when I run a rspec command (>ruby script
\spec spec\views\category_metr
ics\show.html.erb_spec.rb  --backtrace), I am getting an error that
the rails-cucumber gem is not found:

no such file to load -- cucumber-rails
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_re
quire'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`polyglot_origin
al_require'
C:/Ruby/lib/ruby/gems/1.8/gems/polyglot-0.2.9/lib/polyglot.rb:70:in
`require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/
dependenci
es.rb:158:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/lib/rails/gem_dependency.rb:
208:in `l
oad'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/lib/initializer.rb:307:in
`load_gems'

C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/lib/initializer.rb:307:in
`each'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/lib/initializer.rb:307:in
`load_gems'

C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/lib/initializer.rb:169:in
`process'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/lib/initializer.rb:113:in
`send'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/lib/initializer.rb:113:in
`run'
C:/projects/price_prod/branches/dev_kk/config/environment.rb:9
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_re
quire'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
script/spec:7
Missing these required gems:
  cucumber-rails  = 0.2.4

You're running:
  ruby 1.8.6.287 at C:/Ruby/bin/ruby.exe
  rubygems 1.3.5 at C:/Documents and Settings/Home/.gem/ruby/1.8, C:/
Ruby/lib/ru
by/gems/1.8

Run `rake gems:install` to install the missing gems.

I am on windows xp, with following environment:

ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]
Rails 2.3.4

Running rake gems RAILS_ENV = test produces the following
 - [F] haml = 2.0.9
 - [F] authlogic = 2.1.3
    - [R] activesupport
 - [F] rspec-rails = 1.3.2
    - [F] rspec >= 1.3.0
    - [R] rack >= 1.0.0
 - [F] rspec = 1.3.0
 - [F] cucumber = 0.6.2
    - [I] term-ansicolor >= 1.0.4
    - [I] treetop >= 1.4.2
       - [I] polyglot >= 0.2.5
    - [I] polyglot >= 0.2.9
    - [R] builder >= 2.1.2
    - [I] diff-lcs >= 1.1.2
    - [I] json_pure >= 1.2.0
 - [F] cucumber-rails = 0.2.4
    - [F] cucumber >= 0.6.2
       - [I] term-ansicolor >= 1.0.4
       - [I] treetop >= 1.4.2
          - [I] polyglot >= 0.2.5
       - [I] polyglot >= 0.2.9
       - [R] builder >= 2.1.2
       - [I] diff-lcs >= 1.1.2
       - [I] json_pure >= 1.2.0
 - [F] webrat = 0.7.0
    - [I] nokogiri >= 1.2.0
    - [R] rack >= 1.0
    - [I] rack-test >= 0.5.3
       - [R] rack >= 1.0
 - [F] spork = 0.7.5
 - [F] database_cleaner = 0.4.3
 - [F] thoughtbot-factory_girl = 1.2.2

I = Installed
F = Frozen
R = Framework (loaded before rails starts)



More information about the rspec-users mailing list