[rspec-users] Problems running RSpec 2 with autotest/autospec

Michelle Pace lists at ruby-forum.com
Tue Dec 14 08:15:49 EST 2010


David Chelimsky wrote in post #967835:
> ZenTest-4.4.2 will add "." to the $LOAD_PATH, at which point the
> material in
> the book will work as written (except that the file is
> "autotest/discover.rb", not
> "autotest/.autotest/discover.rb") with ruby-1.9.

Ok - I have updated to ZenTest-4.4.2, I've made sure that I have
autotest/discover.rb and that I use 'autotest' in place
of 'autospec'...I'm sorry to say it, but iis still not 'verking:

C:\DEVELOPMENT\twits>autotest
loading autotest/rspec2
bundle exec C:\devtools\Ruby192\bin\ruby -S
C:/devtools/Ruby192/lib/ruby/gems/1.9.1/gems/rspec-core-2
.3.0/bin/rspec --tty 'C:/DEVELOPMENT/twits/spec/twits_spec.rb'
Could not find gem 'rspec (~> 2.1.0, runtime)' in any of the gem sources
listed in your Gemfile.
Interrupt a second time to quit
Terminate batch job (Y/N)?
^C

C:\DEVELOPMENT\twits>ls spec/*
spec/spec_helper.rb  spec/twits_spec.rb


:) sorry David... but got any more pointers for me??

-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list