[rspec-users] Problems running RSpec 2 with autotest/autospec

Michelle Pace lists at ruby-forum.com
Thu Dec 9 20:58:13 EST 2010

Hi David, sorry still no coconut. I should have explained myself better,
I actually need to run the "autospec" command as the book says:
"Thankfully, RSpec comes with a small script named autospec that
reconfigures autotest to run specs instead, so try that..."

So in the below I tried using your " --style rspec2" command for both
autotest and *autospec*. Any ideas how I get autospec to run?

C:\DEVELOPMENT\twits>autospec --style rspec2
REMOVAL NOTICE: you are using behaviour that has been
removed from rspec-2.

* The 'autospec' command is no longer supported.
* Please use 'autotest' insted.

This message will be removed from a future version of rspec.

C:\DEVELOPMENT\twits>autotest --style rspec2
loading autotest/rspec2
bundle exec C:\devtools\Ruby192\bin\ruby -S
.2.1/bin/rspec --tty 'C:/DEVELOPMENT/twits/spec/twits_spec.rb'
Could not find gem 'rspec (~> 2.1.0, runtime)' in any of the gem sources
listed in your Gemfile.
Interrupt a second time to quit
Terminate batch job (Y/N)? y

Another quotation from this book which is sending me crazy:
  "Using RSpec 2?
  The autospec command has been removed from RSpec 2, so
  if you’ve upgraded, you’ll need to do something a little different.
  You’re going to want to create a directory tree in the root
  of your project named autotest/.autotest. Then inside that you
  need to create a file named discover.rb. To that file we’ll need to
  add the statement Autotest.add_discovery { "rspec2" }."

Thanks again,

Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list