[rspec-users] [Sinatra] "tried to create Proc object without a block"

Jason Edwards jtanium at gmail.com
Fri Dec 3 18:12:42 EST 2010

Yeah, that's a major pain...

I put my stuff up here: https://gist.github.com/720605

And later on I found:

I tried to include comments about what I changed to get it to work.
When I found pauldix's, it looked like he had made pretty much all the
same changes I had.

If my Gist and the GitHub project don't help, post your code...


On Fri, Dec 3, 2010 at 3:55 PM, Ernst Arnold <lists at ruby-forum.com> wrote:
> I get the same error message as Jason. However installing rack-test did
> not help in my case. (I am new to Ruby, and don't yet know how to use
> the debugger)
> Tried with rvm use 1.9.2 and rvm use 1.8.7
> Generally I am a bit disappointed that the code from the book needed a
> number of changes to get even this far.
> Ernst
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users

More information about the rspec-users mailing list