[rspec-users] rspec2: autotest keeps rerunning failing tests

Justin Ko jko170 at gmail.com
Mon Aug 30 10:56:16 EDT 2010


hmmmm.... adding autotest-rails did not fix it for me.

On Aug 30, 8:00 am, nathanvda <nathan... at gmail.com> wrote:
> I can't explain why it suddenly did not work anymore, but i readhttp://gist.github.com/365816
> and the only thing i needed to do to make it work was adding the
> following dependencies to my gemfile:
>
> gem "autotest"
> gem "autotest-rails"
>
> The gem autotest-rails was already installed on my system. So can't
> explain why, but now it works.
> There, i fixed it :)
>
> On Aug 30, 9:59 am, nathanvda <nathan... at gmail.com> wrote:
>
>
>
> > Since my update to beta.20 i have this weird thing.
> > Normally i develop with autotest on, and when i get an error: i can
> > check the errors, and they are rerun when i save the files.
>
> > If all my tests pass this is still the current behaviour, but if i
> > have failing tests, autotest will keep running those tests.
> > I am afraid i find that kind of annoying :)
>
> > I am not sure what could cause this.
>
> > In my autotest/discover.rb i have the following lines:
>
> > Autotest.add_discovery { "rails" }
> > Autotest.add_discovery { "rspec2" }
>
> > Is there a way to get the old behaviour back? (tests are only rerun
> > when files have changed)
> > _______________________________________________
> > rspec-users mailing list
> > rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users
>
> _______________________________________________
> rspec-users mailing list
> rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users


More information about the rspec-users mailing list