[rspec-users] Autotest will run features, but not specs

Brennon Bortz brennon at brennonbortz.com
Fri Aug 27 09:29:59 EDT 2010


Strange...that does work, but now autotest seems caught in an infinite loop.  When I run autospec, the specs run, then the features, then the features again...and again...and again...and so on.  If I run autotest as follows: "AUTOFEATURE=false autotest", I don't have the problem.  Any other ideas?

Many thanks,
Brennon

On 27 Aug 2010, at 14:06, David Chelimsky wrote:

> On Aug 27, 2010, at 6:47 AM, Brennon Bortz wrote:
> 
>> Not sure what I must have bumped, but autotest won't run any specs--only features.  No errors are given on startup.  I've taken "export AUTOFEATURE=true" out of my ./bashrc file--now I just get a blank screen when running autotest.  Adding "export RSPEC=true" to .bashrc doesn't change anything either.
> 
> 1. Get rid of 'Autotest.add_discovery { "rails" }' from ./autotest/discover.rb.
> 2. Add autotest-rails to the Gemfile.
> 
> If any of the gems listed in the Gemfile have :path or :git options, you need to run "bundle exec autotest".
> 
> HTH,
> David
> 
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users

Brennon Bortz
Software Researcher
Dundalk Institute of Technology
brennon.bortz at casala.ie
Ph.D. Researcher & Composer - Sonic Arts Research Centre
Queen's University, Belfast
brennon at brennonbortz.com / bbortz01 at qub.ac.uk



More information about the rspec-users mailing list