[rspec-users] rspec can not be found

dwayne dwayne.purper at gmail.com
Thu Aug 26 09:35:14 EDT 2010


Hi guys:

I'm trying to get my RVM/Rails 2 and 3 mixed environment set up, and
I'm still running into problems. Not sure if that's related to rspec
not being found, but here's what's happening:

$ rake spec --trace
(in /Users/dwayne/Sites/casehandler_rails)
** Invoke spec (first_time)
** Invoke db:test:prepare (first_time)
** Invoke db:abort_if_pending_migrations (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:abort_if_pending_migrations
** Execute db:test:prepare
** Invoke db:test:load (first_time)
** Invoke db:test:purge (first_time)
** Invoke environment
** Execute db:test:purge
** Execute db:test:load
** Invoke db:schema:load (first_time)
** Invoke environment
** Execute db:schema:load
** Execute spec
rake aborted!

********************************************************************************
*  You are trying to run an rspec rake task defined in
*  /Users/dwayne/Sites/casehandler_rails/lib/tasks/rspec.rake,
*  but rspec can not be found in vendor/gems, vendor/plugins or system
gems.
********************************************************************************
/Users/dwayne/Sites/casehandler_rails/lib/tasks/rspec.rake:33:in
`initialize'
/Users/dwayne/.rvm/gems/ruby-1.8.7-p174 at rails3/gems/rake-0.8.7/lib/
rake.rb:636:in `call'
/Users/dwayne/.rvm/gems/ruby-1.8.7-p174 at rails3/gems/rake-0.8.7/lib/
rake.rb:636:in `execute'
/Users/dwayne/.rvm/gems/ruby-1.8.7-p174 at rails3/gems/rake-0.8.7/lib/
rake.rb:631:in `each'
/Users/dwayne/.rvm/gems/ruby-1.8.7-p174 at rails3/gems/rake-0.8.7/lib/
rake.rb:631:in `execute'
/Users/dwayne/.rvm/gems/ruby-1.8.7-p174 at rails3/gems/rake-0.8.7/lib/
rake.rb:597:in `invoke_with_call_chain'
/Users/dwayne/.rvm/rubies/ruby-1.8.7-p174/lib/ruby/1.8/monitor.rb:
242:in `synchronize'
...


Gemfile includes:

group :development, :test do
  gem 'rspec'
  gem 'rspec-rails', '>= 2.0.0.beta.19'
  gem 'webrat'
  gem 'capybara'
  gem 'database_cleaner'
  gem 'gherkin', '2.1.5'
  gem 'cucumber-rails', '>=0.3.2'
  gem 'cucumber', '>=0.8.5'
  gem 'spork'
  gem 'launchy'    # So you can do Then show me the page
end


$ bundle show
...
  * rspec (2.0.0.beta.19)
  * rspec-core (2.0.0.beta.19)
  * rspec-expectations (2.0.0.beta.19)
  * rspec-mocks (2.0.0.beta.19)
  * rspec-rails (2.0.0.beta.19)
...

I've run the install scripts, etc.

Is there a reason the gem isn't being found?

Thanks.


More information about the rspec-users mailing list