[rspec-users] JRuby Rcov and Rspec problem.

Benyi Wang bewang.tech at gmail.com
Mon Aug 23 18:01:43 EDT 2010


When I run Rcov using JRuby, the Rcov report always includes some libraries.

JRuby 1.5.1
rcov 0.9.8
rspec 1.3.0
ci_reporter 1.6.2

Here is my Rake file.

require 'rake'
require 'spec/rake/spectask'
require 'ci/reporter/rake/rspec'

task :default => :test

ENV["CI_REPORTS"]="spec-reports"

task :test => [ "ci:setup:rspec", :spec ]

desc "Run all examples"
Spec::Rake::SpecTask.new(:spec) do |t|
  t.spec_files = FileList['spec/**/*_spec.rb']
  t.spec_opts = [ "--diff" ]
  t.rcov = true
  t.rcov_opts = [ '--exclude', 'spec' ]
end

I run command "jruby --debug -S rake"

Then I will find "xxx-jruby-1_5_1-lib-ruby-1_8-time_rb.html" for class Time.

If I run other Ruby interpreter, it won't have this issue.

Does somebody have the same issue? And how to fix it.

Thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20100823/a34624ee/attachment.html>


More information about the rspec-users mailing list