[rspec-users] 2.0.0.beta.19 installation problem

David Chelimsky dchelimsky at gmail.com
Mon Aug 16 07:22:23 EDT 2010


On Aug 13, 2010, at 11:33 PM, Craig Castelaz wrote:

> I purchased the beta version of the PragBook yesterday, but didn't get
> a chance to begin reading until tonight.  I'm currently stuck on
> installing rspec.
> 
> ~$ sudo gem install rspec --version 2.0.0.beta.19
> **************************************************
>  Thank you for installing rspec-core-2.0.0.beta.19
>  Please be sure to look at Upgrade.markdown to see what might have changed
>  since the last release.
> **************************************************
> **************************************************
>  Thank you for installing rspec-expectations-2.0.0.beta.19
> **************************************************
> **************************************************
>  Thank you for installing rspec-mocks-2.0.0.beta.19
> **************************************************
> ERROR:  Error installing rspec:
> 	rspec requires rspec-core (= 2.0.0.beta.19, runtime)
> 
> I'm a bit mystified because the process begins by installing
> rspec-core-2.0.0.beta.19, but ends by telling me rspec-core
> (2.0.0.beta.19) is required.  I'm running Ruby 1.8.7 on OS 10.6.4 if
> that's of any help.

What version of rubygems do you have installed? If anything less than 1.3.7, please upgrade. Previous versions had some issues related to prerelease dependencies, but they've all been fixed in 1.3.7.

HTH,
David

> Thanks,
> Craig
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users



More information about the rspec-users mailing list