[rspec-users] 2.0.0.beta.19 installation problem

Craig Castelaz craig.castelaz at gmail.com
Sat Aug 14 00:33:26 EDT 2010


I purchased the beta version of the PragBook yesterday, but didn't get
a chance to begin reading until tonight.  I'm currently stuck on
installing rspec.

~$ sudo gem install rspec --version 2.0.0.beta.19
**************************************************
  Thank you for installing rspec-core-2.0.0.beta.19
  Please be sure to look at Upgrade.markdown to see what might have changed
  since the last release.
**************************************************
**************************************************
  Thank you for installing rspec-expectations-2.0.0.beta.19
**************************************************
**************************************************
  Thank you for installing rspec-mocks-2.0.0.beta.19
**************************************************
ERROR:  Error installing rspec:
	rspec requires rspec-core (= 2.0.0.beta.19, runtime)

I'm a bit mystified because the process begins by installing
rspec-core-2.0.0.beta.19, but ends by telling me rspec-core
(2.0.0.beta.19) is required.  I'm running Ruby 1.8.7 on OS 10.6.4 if
that's of any help.

Thanks,
Craig


More information about the rspec-users mailing list