[rspec-users] State of autospec/test and Rails 3

David Chelimsky dchelimsky at gmail.com
Wed Apr 14 09:37:22 EDT 2010


On Apr 14, 2010, at 7:37 AM, Mikel Lindsaar wrote:

> Hi all,
> 
> David, before I begin, thanks for your hard work :)
> 
> I saw a thread or a blog post, I think it was on your site David, that Autotest is not working with Rails at the moment, circa beta4.
> 
> Has that since changed?  If not, anything I can do to help?
> 
> At least on beta6 it still seems to be failing with:
> 
> $ autotest
> loading autotest/rails
> /Users/mikel/.rvm/gems/ruby-1.8.7-p249 at t/gems/ZenTest-4.3.1/lib/autotest.rb:181:in `load': no such file to load -- ./.autotest (LoadError)
> 	from /Users/mikel/.rvm/gems/ruby-1.8.7-p249 at t/gems/ZenTest-4.3.1/lib/autotest.rb:181:in `initialize'
> 	from /Users/mikel/.rvm/gems/ruby-1.8.7-p249 at t/gems/ZenTest-4.3.1/lib/autotest.rb:180:in `each'
> 	from /Users/mikel/.rvm/gems/ruby-1.8.7-p249 at t/gems/ZenTest-4.3.1/lib/autotest.rb:180:in `initialize'
> 	from /Users/mikel/.rvm/gems/ruby-1.8.7-p249 at t/gems/autotest-rails-4.1.0/lib/autotest/rails.rb:7:in `initialize'
> 	from /Users/mikel/.rvm/gems/ruby-1.8.7-p249 at t/gems/ZenTest-4.3.1/lib/autotest.rb:124:in `new'
> 	from /Users/mikel/.rvm/gems/ruby-1.8.7-p249 at t/gems/ZenTest-4.3.1/lib/autotest.rb:124:in `run'
> 	from /Users/mikel/.rvm/gems/ruby-1.8.7-p249 at t/gems/ZenTest-4.3.1/bin/autotest:55
> 
> 
> relevant gem list:
> 
> autotest-rails (4.1.0)
> rspec-core (2.0.0.beta.6)
> rspec-expectations (2.0.0.beta.6)
> rspec-mocks (2.0.0.beta.6)
> ZenTest (4.3.1)
> 
> 
> Autotest file:
> 
> $ cat .autotest/discover.rb 
> Autotest.add_discovery { "rspec2" }

Hi Mikel,

I'm having success with it. Take a look at http://gist.github.com/365816 - anything you're missing there?

Cheers,
David
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20100414/372d513d/attachment.html>


More information about the rspec-users mailing list