[rspec-users] Broken pipe error in progress_bar_formatter when autotest detects changes and try to run the specs again

Edgar Gonzalez edgargonzalez at gmail.com
Thu Apr 1 11:27:22 EDT 2010


Hi,

I have a Broken pipe error in progress_bar_formatter when autotest detects
changes and try to run the specs again:

508 $ autospec
loading autotest/rspec
/usr/bin/ruby1.8 /usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/bin/spec --autospec
/home/edgar/sandboxes/buzz/models/spec/domain_spec.rb
/home/edgar/sandboxes/buzz/models/spec/base_spec.rb -O spec/spec.opts
.............

Finished in 0.02858 seconds

13 examples, 0 failures
/usr/bin/ruby1.8 /usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/bin/spec --autospec
/home/edgar/sandboxes/buzz/models/spec/base_spec.rb -O spec/spec.opts
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/formatter/progress_bar_formatter.rb:17:in
`flush': Broken pipe (Errno::EPIPE)
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/formatter/progress_bar_formatter.rb:17:in
`example_passed'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/reporter.rb:136:in
`example_passed'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/reporter.rb:136:in
`each'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/reporter.rb:136:in
`example_passed'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/reporter.rb:31:in
`example_finished'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/example/example_methods.rb:55:in
`execute'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/example/example_group_methods.rb:214:in
`run_examples'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/example/example_group_methods.rb:212:in
`each'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/example/example_group_methods.rb:212:in
`run_examples'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/example/example_group_methods.rb:103:in
`run'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/example_group_runner.rb:23:in
`run'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/example_group_runner.rb:22:in
`each'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/example_group_runner.rb:22:in
`run'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/options.rb:152:in
`run_examples'
    from
/usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/lib/spec/runner/command_line.rb:9:in
`run'
    from /usr/lib/ruby/gems/1.8/gems/rspec-1.3.0/bin/spec:5
Interrupt a second time to quit


I guess it is related to ruby 1.8 vs 1.9 issue, like this
http://rubyforge.org/tracker/index.php?func=detail&aid=28034&group_id=419&atid=1678

My environment:
ruby 1.8.6 (2007-09-24 patchlevel 111) [i486-linux]
rubygem 1.3.6
rspec (1.3.0, 1.2.9, 1.2.4, 1.1.12, 1.1.4)
rspec-rails (1.3.2, 1.2.9, 1.2.4, 1.1.12)
ZenTest (4.3.1)
autotest-rails (4.1.0)

any clue about it?

Thanks


-- 
Edgar González González
E-mail: edgargonzalez at gmail.com
http://twitter.com/edgar
http://www.hasmanydevelopers.com
http://edgar.gonzalez.net.ve
--
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20100401/21e5abcb/attachment.html>


More information about the rspec-users mailing list