[rspec-users] Error executing specs using Ruby 1.9.1p243 and RSpec 1.2.9

Scott Taylor scott at railsnewbie.com
Mon Nov 23 22:36:34 EST 2009


On Nov 23, 2009, at 9:35 PM, David Chelimsky wrote:

> On Fri, Nov 20, 2009 at 9:06 PM, Bogdan Dumitru <dumbogdan at gmail.com> wrote:
> The syntax for use_fakefs changed in version 0.2.1 and the fixtures
> for rspec are generating errors, but it can be solved easily.
> Have to change ...
> describe "smth" do
>   extend FakeFS::SpecHelpers
>   use_fakefs
>   ...
> end
> To...
> extend FakeFS::SpecHelpers
> use_fakefs describe "smth" do ... end
> 
> As it seems the use_fakefs method now takes the describe block as a
> parameter and thus the error regarding the wrong number of parameters.
> 
> I had to do this slightly differently, but got it to work with fakefs-0.2.1. Fixed in git.
> 
> Cheers,
> David

You can use include, too:

  module SpecHelpers
    def self.extended(example_group)
      example_group.use_fakefs(example_group)
    end

    def self.included(example_group)
      example_group.extend self
    end
  ..
 end

Scott


>  
> 
> 
> On Nov 8, 3:30 pm, David Chelimsky <dchelim... at gmail.com> wrote:
> > On Sun, Nov 8, 2009 at 2:35 AM, Conrad Taylor <conra... at gmail.com> wrote:
> > > David, I'm still seeing the issue.  Thus, here's a transcript of my
> > > activity:
> >
> > >http://pastie.org/688639
> >
> > $ gem which fakefs
> > (checking gem bmabey-fakefs-0.1.1.1 for fakefs)
> > /Users/david/.rvm/gems/ruby/1.9.1/gems/bmabey-fakefs-0.1.1.1/lib/fakefs.rb
> >
> > What version of fakefs are you using?
> >
> >
> >
> > > -Conrad
> >
> > > On Nov 4, 2:28 pm, David Chelimsky <dchelim... at gmail.com> wrote:
> > > > On Tue, Nov 3, 2009 at 7:25 AM, Conrad Taylor <conra... at gmail.com>
> > > wrote:
> > > > > Hi, 'rake spec' failed to run on Ruby 1.9.1p243 and RSpec 1.2.9.
> >
> > > > Hi Conrad,
> >
> > > > If this was a problem in the gem, it is now fixed:
> >
> > > > $ rvm 1.9.1
> > > > $ which ruby
> > > > /Users/david/.rvm/ruby-1.9.1-p243/bin/ruby
> > > > $ rake spec
> > > > ...
> > > > 1522 examples, 0 failures, 2 pending
> >
> > > > Cheers,
> > > > David
> >
> > > > > I'm
> > > > > getting the following error message when I run the specs:
> >
> > > > > /opt/local/lib/ruby/gems/1.9.1/gems/rspec-1.2.9/spec/spec/runner/
> > > > > option_parser_spec.rb:21:in `block (2 levels) in <top (required)>':
> > > > > wrong number of arguments (0 for 1) (ArgumentError)
> >
> > > > > After analyzing the error message, it appears that "use_fakefs" method
> > > > > on lines 21 and 522 of the
> >
> > > > > option_parser_spec.rb
> >
> > > > > should take an argument.
> >
> > > > > -Conrad
> >
> > > > > _______________________________________________
> > > > > rspec-users mailing list
> > > > > rspec-us... at rubyforge.org
> > > > >http://rubyforge.org/mailman/listinfo/rspec-users
> >
> > > > _______________________________________________
> > > > rspec-users mailing list
> > > > rspec-us... at rubyforge.orghttp://
> > > rubyforge.org/mailman/listinfo/rspec-users
> > > _______________________________________________
> > > rspec-users mailing list
> > > rspec-us... at rubyforge.org
> > >http://rubyforge.org/mailman/listinfo/rspec-users
> >
> >
> >
> > _______________________________________________
> > rspec-users mailing list
> > rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
> 
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20091123/c7a95b80/attachment.html>


More information about the rspec-users mailing list