[rspec-users] Error executing specs using Ruby 1.9.1p243 and RSpec 1.2.9

Conrad Taylor conradwt at gmail.com
Tue Nov 3 07:25:52 EST 2009


Hi, 'rake spec' failed to run on Ruby 1.9.1p243 and RSpec 1.2.9.  I'm
getting the following error message when I run the specs:

/opt/local/lib/ruby/gems/1.9.1/gems/rspec-1.2.9/spec/spec/runner/
option_parser_spec.rb:21:in `block (2 levels) in <top (required)>':
wrong number of arguments (0 for 1) (ArgumentError)

After analyzing the error message, it appears that "use_fakefs" method
on lines 21 and 522 of the

option_parser_spec.rb

should take an argument.

-Conrad



More information about the rspec-users mailing list