[rspec-users] DeepTest with 1.2.6?

Ben Mabey ben at benmabey.com
Thu May 28 10:03:38 EDT 2009


Scott Taylor wrote:
> Adam Anderson wrote:
>> Just curious if anyone is running DeepTest with rspec 1.2.6. I can't 
>> even do a '$ rake -T' on the deep-test repo at 
>> git://github.com/qxjit/deep-test.git 
>> <http://github.com/qxjit/deep-test.git>
>>
>> When I try to run deep_test using their provided rspec example at 
>> http://github.com/qxjit/deep-test it blows up and produces the 
>> following:
>> Warning: DeepTest will run before(:all) and after(:all) blocks for 
>> *every* test that is run.  To remove this warning either convert all 
>> before/after blocks to each blocks or set 
>> $show_deep_test_all_block_warning to false
>> [DeepTest] Started DeepTest service at druby://0.0.0.0:6969 
>> <http://0.0.0.0:6969>
>
> My impression is that it was always sort of buggy and it was hard to 
> reproduce certain bugs in certain configurations - so I'm not sure if 
> it ever worked.  I never got it to fully work on my own machine.
>
> You might try contacting David Vollbracht, who was the one who added 
> in rspec support (this was probably 6 months ago or so now).
>
> I'd be interested in hearing if anyone is actually using it.
>
I tried using DeepTest but I never had success with it.  I was able to 
get it to run but on a single machine with two workers (for it's two 
cores) and it ran considerably slower than just running rspec alone.  I 
tried it on a brand new app and saw the same results.  Support was added 
for RSpec but I highly doubt anyone really used it in real life.  I 
would love to hear otherwise though.

-Ben


More information about the rspec-users mailing list