[rspec-users] undefined method `assert_select'

David Chelimsky dchelimsky at gmail.com
Sat May 23 16:46:32 EDT 2009


On Sat, May 23, 2009 at 3:00 PM, Sarah Allen <lists at ruby-forum.com> wrote:
> Sarah Allen wrote:
>> Sarah Allen wrote:
>>> line 17 is:
>>>       html.should have_tag('script', /swfobject.embedSWF/)
>>
>> I order to use have_tag, it appears I have to include:
>>
>> # just enough infrastructure to get 'assert_select' to work
>> require 'action_controller'
>> require 'action_controller/assertions/selector_assertions'
>> include ActionController::Assertions::SelectorAssertions
>
> Confirmed that this is is required in Rails 2.3.2 and not in 2.1.0,
> although I still don't understand why.

Me neither :)

What version of rspec are you using?

>
> Sarah
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list