[rspec-users] Error in executing controller spec

Amit Kulkarni lists at ruby-forum.com
Wed May 20 02:47:44 EDT 2009

Amit Kulkarni wrote:
> David Chelimsky wrote:
>> On Tue, May 19, 2009 at 9:04 AM, Amit Kulkarni <lists at ruby-forum.com> 
>> wrote:
>>> but i am getting the same error which says  RuntimeError in
>>> Files/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.2/lib/action_control
>>> ./channels_controller_spec1.rb:149:
>> It looks like you're calling the file from the spec/controllers
>> directory. Just for fun, step up to the project root and run:
>> script/spec spec/controllers/channels_controller_spec1.rb
> Hey It worked thanks a lot. :-)
> Can you tell me the difference why it was not running earlier and now it 
> is running.Just for my understanding.

It is not the case that i will always run spec from the root project.So 
if i want to run from spec/controllers direcrtory then what should i do 
since i am getting the error.
Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list