[rspec-users] [Cucumber] gem missing dependencies

Kero van Gelder kero at chello.nl
Sun May 3 18:21:09 EDT 2009


> Polyglot requires hoe because it's built using "newgem". It's a
> nuisance, and I'll be happy to remove it, or make hoe a dev-time
> dependency only if possible. I've contacted Dr Nic to ask how to
> proceed. In my view, using hoe shouldn't add a runtime dependency.

Hm, snippet from long `p spec` (from my prev email):
 @dependencies=[#<Gem::Dependency:0xb7c922fc @version_requirement=nil, @name="hoe", @version_requirements=#<Gem::Requirement:0xb7c922c0 @version=nil, @requirements=[[">=", #<Gem::Version           
+"1.8.0">]]>, @type=:runtime>]

So your dependency is/was runtime-only, it seems.
But the stuff got fixed in the meantime!
I'm guessing it's the rubygems upgrade on my system.

$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]
$ gem -v
1.3.2
$ gem list

*** LOCAL GEMS ***

builder (2.1.2)
calibre-semaphore (1.0.0)
cucumber (0.3.2)
diff-lcs (1.1.2)
polyglot (0.2.5)
rspec (1.2.6)
term-ansicolor (1.0.3)
treetop (1.2.5)
$ gem dependency polyglot
Gem polyglot-0.2.5
  hoe (>= 1.8.0, development)     <= not runtime anymore! same 0.2.5 polyglot gem!

$ cucumber
0 scenarios ()
0 steps ()
$

Bye,
Kero.

___
How can I change the world if I can't even change myself?
  -- Faithless, Salva Mea


More information about the rspec-users mailing list