[rspec-users] DRB errors running rake pre_commit

Doug bianster at gmail.com
Sun May 3 06:48:57 EDT 2009


Thanks David, that did it for me.

On May 2, 8:00 pm, David Chelimsky <dchelim... at gmail.com> wrote:
> On Sat, May 2, 2009 at 2:11 AM, Doug <bians... at gmail.com> wrote:
> > Hi list,
>
> > I checked out the rspec-dev repository on a MBP (Leopard) and tried to
> > run the pre_commit task after going through the setup/configuration
> > steps onhttp://wiki.github.com/dchelimsky/rspec/contribute.
>
> > I'm getting DRB errors related to script/spec_server when running
> > specs: Address already in use - bind(2) (Errno::EADDRINUSE). Running
> > lsof -i tcp:8989 shows:
>
> > ruby    9674 douglas    5u  IPv4 0x6538a68      0t0  TCP
> > localhost:sunwebadmins (LISTEN)
>
> > I've tried changing the DRB port to 20111 and running rake pre_commit
> > again but the same problem comes up. Is this something people have
> > come across before?
>
> I actually just noticed it a couple of days ago. I was able to resolve
> it by building and installing the rspec gem, so there is an apparent
> dependency on that being present. We're going to be re-vamping (read
> *simplifying*) the whole rspec-dev setup in the next month or so, so
> I'm not going to try to fix this right now, but installing the gem
> should solve it for you.
>
> Cheers,
> David
> _______________________________________________
> rspec-users mailing list
> rspec-us... at rubyforge.orghttp://rubyforge.org/mailman/listinfo/rspec-users


More information about the rspec-users mailing list