[rspec-users] [rspec]. Inexplicable error in simple specs

Juanma Cervera lists at ruby-forum.com
Sun May 3 03:59:42 EDT 2009


I am having strange errors running some specs.

I have just installed the nifty_scaffolds gem from Ryan Bates, and ran
"script/generate nifty_authentication --rspec --haml", I have prepared
the databases, and run the specs, and I have almost all the specs
The odd thing is that it only fails when I run all the spec together,
but not
when I ran models and controllers independently.

"rake spec:models" pass for all the specs
"rake spec:controllers" pass for all the specs.

But "rake spec" fails in a dozen of model tests. Also "autospec" fails.

The code seems clear and ok, and I can't understand why even simple
specs for require presence of a field fails.

I have only notice as unusual the use of view integration in the
controllers specs. Does anyone know about something I can be missing?

Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list