[rspec-users] Rspec weird behaviour

David Chelimsky dchelimsky at gmail.com
Mon Mar 23 08:10:37 EDT 2009


On Mon, Mar 23, 2009 at 4:41 AM, andrea <longhiandrea at gmail.com> wrote:
> Hi,
> I recently migrated from classic rails testing to Rspec, so I am
> pretty new to the framework and still learning. I am getting weird
> errors on an ActiveRecord model test, here is the basic class model
> definition:
>
> class Size < ActiveRecord::Base
>  has_many :quantities, :dependent => :destroy
>  validates_presence_of :name
>  validates_uniqueness_of :name, :case_sensitive => false
> end
>
> and this is the faulty spec:
>  it 'new size should have an error on name' do
>    Size.new.should have(1).error_on(:name)
>  end
>
> the red response is:
>  'new size should have an error on name' FAILED
>  expected 1 error on :name, got 0
>
> if I change the spec to read like this:
>  Size.new.should have(:no).error_on(:name)
>
> I still get a red response:
>  'new size should have an error on name' FAILED
>  expected 0 error on :name, got 1
>
> Guess the problem is the model class name (Size) as I don't get such
> weird stuff from other classes... can I fix this somehow?

Hi Andrea,

I just tried this myself (because I wanted to see if the class name
was really the problem) and "Size.new.should have(1).error_on(:name)"
passed for me. I also tried "Size.new.should
have(:no).errors_on(:name)" and that failed correctly. So something
else is amiss in this case.

If this persists, please submit a bug report to
http://rspec.lighthouseapp.com and include a zipped up app that I can
run to see the problem.

Thanks,
David

>
> Thanks
>
> Andrea
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list