[rspec-users] New User Issues

David Chelimsky dchelimsky at gmail.com
Sat Mar 21 10:54:50 EDT 2009


2009/3/20 Scott LaBounty <slabounty at gmail.com>:
> I just found RSpec and was trying to do the example on the main page for
> RSpec (the bowling example). I'm using Ubuntu and did the normal "sudo gem
> install rspec" and then tried to create the bowling_spec.rb file. When I ran
> spec bowling_spec.rb, I was missing the cucumber gem, installed that, reran
> and was missing the hoe gem, installed that,

Cucumber and hoe are developer dependencies. You should probably
upgrade rubygems - sounds like you're using an old version that
doesn't know the difference between developer dependencies and
standard runtime dependencies.

I should probably make it so those dependencies don't exist at all
unless you have a new enough rubygems to make the distinction.

> reran and it gave me the a
> missing 'require' from the bowling_spec since I didn't have a bowling.rb
> file. Is that expected?

The example fails to point that out, but yes, it is the expected
behaviour if the file doesn't exist.

> From the example, it didn't seem like it would be.
> When I then added the bowling.rb file and reran everything looked correct
> except that it wasn't in color (i.e. no green). Is that expected or do I
> need to do something differnt to get this to work?

Add the --color option to the command line and you'll get color.

> I'm running ruby 1.8.6 if
> it makes a difference.

Nope - the example needs some fixing. I'm doing a bug-fix release in
the next few days, and I'll be sure to fix the example so it works as
a mini-tutorial when I do that release.

Thanks!

David



>
> Thanks,
>
> --
> Scott
> http://steamcode.blogspot.com/
>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list