[rspec-users] Having a problem with new webrat matchers in cucumber 2

James Byrne lists at ruby-forum.com
Fri Mar 20 09:45:23 EDT 2009

I ran script/generate cucumber and since then I am having a few
difficulties.  For instance, take this case:

When /see (?:an|the) authori(?:s|z)ation required message/ do
  Then "I should see \"You are not authori(?:s|z)ed\""

Now gives:

    And they should see an authorization required message
           # features/app/step_definitions/authorization_steps.rb:1
      expected the following element's content to include
           "You are not authori(?:s|z)ed":
          You are not authorized to access the requested resource

This matcher worked perfectly well in cucumber up to and including  v
0.2.0, until after I ran script/generate cucumber.  The problem seems to
be the substitution in webrat_steps.rb of:

 response.should contain(text)
 response.body.should =~ /#{text}/m

I have reverted to the old style matcher which solves my immediate
problem.  My question is: Was subpattern matching deliberately removed
from this matcher or is this an error?

P.S. This is Canada and up here both 'ise' (UK) and 'ize' (US) endings
are commonly used. However, generally those who choose one despise those
who choose the other.  So as to have peace over a triviality I provide
for both.
Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list