[rspec-users] rspec, rspec-rails 1.1.99-12 and script/spec 'no such file to load -- spec'

rockrep rockrep at gmail.com
Fri Mar 6 17:02:59 EST 2009


Hi David, all:

I just recently upgraded to Rails 2.3.1RC2 (Mac OS.X 10.5.6, ruby
1.8.7 (2008-08-11 patchlevel 72) [i686-darwin9])  and have been
dilligently following the instructions for upgrading rspec and rspec-
rails according to:  http://wiki.github.com/dchelimsky/rspec/rails-with-rspec-gems.
I have successfully built the rspec and rspec-rails gems, installed
and unpacked them, and ran script/generate rspec successfully.

'rake spec' works fine, however 'script/spec' fails with error:
$ script/spec spec
script/spec:3:in `require': no such file to load -- spec (LoadError)

script/spec looks like:
#!/usr/bin/env ruby
$LOAD_PATH.unshift(File.expand_path(File.dirname(__FILE__) + "/../
vendor/plugins/rspec/lib"))
require 'spec'
exit ::Spec::Runner::CommandLine.run

and 'rake gems RAILS_ENV=test' returns:
 - [R] rspec >= 1.1.99.12
 - [F] rspec-rails >= 1.1.99.12
    - [R] rspec = 1.1.99.12
    - [F] rack = 0.9.1
    - [ ] cucumber >= 0.1.13
    - [ ] hoe >= 1.9.0

I = Installed
F = Frozen
R = Framework (loaded before rails starts)

rspec does not exist in vendor/gems, but rspec-rails does.  It seems
it's marked as 'R' which (1) I'm not certain I understand why, and (2)
seems to prevent unpacking into vendor/gems.   In any case, I would
like to resolve the issue with script/spec.

Since rspec is also not installed in vendor/plugins the LOAD_PATH line
in script/spec looks odd, but I'm not sure it's the cause.

Any pointers greatly appreciated.  Thanks,

Michael



More information about the rspec-users mailing list