[rspec-users] Sinitra 0.9.1 Webrat 0.4.2 Cuc problem

Andrew Premdas apremdas at gmail.com
Tue Mar 3 23:39:30 EST 2009


Have created sample sinatra cucumber app as suggested on wiki. Tried both
env.rb configurations from there and aslaks git repo. With this combination
of gems I get the following error doing basic cuc tests

 When I visit '/foo'                                       #
features/step_definitions/general.rb:1
      PATH_INFO must start with / (Rack::Lint::LintError)
      /Library/Ruby/Gems/1.8/gems/rack-0.9.1/lib/rack/lint.rb:16:in `assert'
      /Library/Ruby/Gems/1.8/gems/rack-0.9.1/lib/rack/lint.rb:178:in
`check_env'
      /Library/Ruby/Gems/1.8/gems/rack-0.9.1/lib/rack/lint.rb:39:in `_call'
      /Library/Ruby/Gems/1.8/gems/rack-0.9.1/lib/rack/lint.rb:33:in `call'
      /Library/Ruby/Gems/1.8/gems/rack-0.9.1/lib/rack/mock.rb:70:in
`request'
      /Library/Ruby/Gems/1.8/gems/sinatra-0.9.1/lib/sinatra/test.rb:41:in
`make_request'
      /Library/Ruby/Gems/1.8/gems/sinatra-0.9.1/lib/sinatra/test.rb:44:in
`orig_get'
      /Library/Ruby/Gems/1.8/gems/webrat-0.4.2/lib/webrat/sinatra.rb:26:in
`__send__'
      /Library/Ruby/Gems/1.8/gems/webrat-0.4.2/lib/webrat/sinatra.rb:26:in
`get'

/Library/Ruby/Gems/1.8/gems/webrat-0.4.2/lib/webrat/core/session.rb:104:in
`send'

/Library/Ruby/Gems/1.8/gems/webrat-0.4.2/lib/webrat/core/session.rb:104:in
`request_page'

/Library/Ruby/Gems/1.8/gems/webrat-0.4.2/lib/webrat/core/session.rb:205:in
`visit'
      ./features/step_definitions/general.rb:3:in `When /^I visit (.*)$/'
      features/basic.feature:17:in `When I visit '/foo''


Afraid I can't expand on this as I can't getting debugging working with cuc
and sinatra.

All best

Andrew
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20090304/7351c907/attachment.html>


More information about the rspec-users mailing list