[rspec-users] Autospec Infinite Loop ??

David Chelimsky dchelimsky at gmail.com
Mon Jun 15 08:36:25 EDT 2009


On Mon, Jun 15, 2009 at 7:18 AM, Bart Zonneveld<zuperinfinite at gmail.com> wrote:
>
> On Jun 13, 2009, at 11:19 PM, Alexandre Da Silva wrote:
>
>> David Chelimsky wrote:
>>>
>>> On Fri, Jun 12, 2009 at 6:42 AM, Alexandre Da
>>> Silva<lists at ruby-forum.com> wrote:
>>>>
>>>> rails blogapp
>>>> cd blogapp
>>>> script/generate rspec
>>>> script/generate rspec_scaffold posts title:string body:text
>>>> rake db:migrate
>>>> autospec
>>>
>>> I just copied this all into a shell and the specs ran only once and
>>> stopped, as expected.
>>>
>>> rspec-1.2.6
>>> rspec-rails-1.2.6
>>> ZenTest-4.1.1
>>> Mac OS 10.5.7
>>> ruby 1.8.6 (2008-08-11 patchlevel 287) [universal-darwin9.0]
>>>
>>> Anything different in your environment?
>>>
>>> Also, I tried this with and without some autotest exceptions set up in
>>> my ~/.autotest file, and it worked correctly in either case.
>>
>> gems are the same... but I have a lot of other gems. I tested removing
>> all gems and reinstaling one by one... after all gems installed (except
>> remarkable gem) the test above ran as expected.
>>
>> After some inspects I found in different projects two possible sources
>> of the problem.
>>
>> Source one: remarkable gem
>> if you use remarkable, try do uninstall that gem and test if the testes
>> continue looping
>>
>> Source two: localized_dates plugin
>> if you use this plugin try removing it and run the tests again. I mean
>> that localized_dates plugin is not needed in rails 2.3.3 anymore.
>
> I don't have these plugins or gems, but I found out that downgrading ZenTest
> to version 4.0.0 solved the problem.

Did you install the autotest-rails gem per the ZenTest 4.1 release notes?

>
> HTH,
> bartz
>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list