[rspec-users] Problem while generating rspec model in Rails Project

Ninad Pol lists at ruby-forum.com
Mon Jun 15 02:42:53 EDT 2009


Thanks for your reply.

No, above command does not give me same error. However it creates only 
the model file under \app\models and asks whether to overwrite it. But 
my aim is to create rspec file under \spec\models with the actual model 
file created under \app\models remaining unchanged. So using the rails 
generator does not meet my objective and i have to use rspec generator 
to meet the requirement.

Ideal schenario should be that rspec generator creates the desired rspec 
file under \spec\models and while creating actual model file under 
\app\models it should ask for whether to overwrite it. I am not getting 
this schenario may be because i am missing something.It would be really 
helpful if you could help me out in this.


David Chelimsky wrote:
> On Fri, Jun 12, 2009 at 5:35 AM, Ninad Pol<lists at ruby-forum.com> wrote:
>>
>> by on Rails.
>>
>>
>> So can anybody please help me out regarding this issue. whether this is
>> related to version problem or what else earliest?
> 
> I'm not sure where this message is coming from but it's not coming
> from rspec. Have you tried generating with the rails generator?
> 
> ruby script/generate model Client
> 
> Does that give you the same error?

-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list