[rspec-users] Autospec Infinite Loop ??

David Chelimsky dchelimsky at gmail.com
Fri Jun 12 10:20:19 EDT 2009


On Fri, Jun 12, 2009 at 6:42 AM, Alexandre Da Silva<lists at ruby-forum.com> wrote:
> Jarmo Pertman wrote:
>> Do you have any files, which might be changed during your failing
>> tests? Some temporary files or whatsoever? If that's the case, then
>> autotest thinks that you have made some changes already and tries to
>> run again. Solution would be to put that file into ignore list for
>> autotest.
>
> No... all was working some days ago.
> in fact the same issue occurs with a new fresh project. Here is my test
>
> rails blogapp
> cd blogapp
> script/generate rspec
> script/generate rspec_scaffold posts title:string body:text
> rake db:migrate
> autospec

I just copied this all into a shell and the specs ran only once and
stopped, as expected.

rspec-1.2.6
rspec-rails-1.2.6
ZenTest-4.1.1
Mac OS 10.5.7
ruby 1.8.6 (2008-08-11 patchlevel 287) [universal-darwin9.0]

Anything different in your environment?

Also, I tried this with and without some autotest exceptions set up in
my ~/.autotest file, and it worked correctly in either case.

>
>
> This will cause error because posts is pluralized... so my autospec
> loops forever.
> all my applications are issuing the same behavior.
>
> I am with latest rspec and rspec-rails gems (1.2.6 I mean)
> when I back to my computer, I will provide a list of all my installed
> gems.
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list